avatar

John Eppstein

Platinum Blonde

Posts: 1,274 Member Since: 31/05/2015

Lead

Feb 25 17 10:04 PM

Tags : :

Hi guys! The power supply for my ADR SCAMP rack appears to have gone titrs up - the plus side is putting out around 4.9 volts instead of 30 and the minus side is doing  maybe 3.9. None of the lights are lighting. This is the 250 watt power supply, not the rack mount version. Does anybody have a schematic they could send me? Altenatively, does anyone have a spare supply they'd be willing to sell?  There are a couiple on Ebay, but they seem a bit dodgy to me. There was a rack mount version liosted for months and months but it's no longer available.

Thanks in advance!
Quote    Reply   
avatar

jeff goodman

New Forum Friend

Posts: 9 Member Since:26/01/2011

#3 [url]

Feb 26 17 4:29 PM

Scamp manuals and docs

Go to analogrules.com/manuals/scamp1.html

They have a .rar file of the Scamp S26 and S60 power supply manual at the bottom of the page.

Jeff mixxymixxymixxy

Quote    Reply   
avatar

John Eppstein

Platinum Blonde

Posts: 1,274 Member Since:31/05/2015

#4 [url]

Feb 27 17 2:55 PM

jeff goodman wrote:
Go to analogrules.com/manuals/scamp1.html

They have a .rar file of the Scamp S26 and S60 power supply manual at the bottom of the page.

Thanks! So he finally re-uploaded his files - last time I looked there more than half the links were dead and emailing him did no good. There are at least 3 versions of the SCAMP supply - his archive contains two of them and fortunately one appears to be the correct one. I'll see when I get into it....

Thanks again!

Last Edited By: John Eppstein Apr 19 17 10:42 PM. Edited 1 time.

Quote    Reply   
Add Reply

Quick Reply

bbcode help